[cvsnt] CVS HEAD stuck?!?

Arthur Barrett arthur.barrett at march-hare.com
Fri Apr 20 13:45:26 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


Yep I think that explains it. I can't be entirely sure but I do remember
that a release around that time had a problem if encryption and
compression were enabled - but was resolved in a later release and that
is what you are seeing.



-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf
Of Christian Hack
Sent: Friday, 20 April 2007 4:53 PM
To: cvsnt at cvsnt.org
Subject: Re: [cvsnt] CVS HEAD stuck?!?

> > TortoiseCVS 1.10.1 RC4 installs 2382 which although
> > works installs a whole CVS service/server on every 
> > client which I do not want. 
> That's one of the reasons it's RC not STABLE.
> The STABLE version will install 2.5.04 client only.

Fair enough. I did only want to install 1.8.31 though which is the
stable version but it has the problem below. I just tried the upcoming
RC to see if it was OK. And generally it was except it ran the

> > Nasty. The latest TortoiseCVS release uses 2.5.03 2260
> > of cvs.exe which doesn't want to play with 2.5.03 2382 
> > of the server.
> I've never seen this.
> Enable server side tracing and then on a client do something like "cvs

> -ttt ls", look at the trace and see where it's stopping, or e-mail the

> last 20 or so lines to the list if it makes no sense to you.

I enabled "Allow clients to trace server" on the advanced tab - I assume
that's the same thing. However it doesn't seem to make a difference
whether it's enabled or not. I always get the same result so I'm not
100% sure what you are suggest is correctly enabled.

14:45:13:   -> Tracelevel set to 3.  PID is 3808
14:45:13:   -> Session ID is ee0462861790bfc
14:45:13:   -> Session time is Fri Apr 20 06:45:13 2007
14:45:13:   -> Loading protocol sserver as sserver_protocol.dll
14:45:13:   -> CLibraryAccess::Load loading
14:45:13:   -> main loop with
14:45:28:   -> Encryption enabled
14:45:28:   -> Compression enabled

And that's it... It will just sit there forever (well 5 minutes so far).
Looking on my firewall I can the traffic stopped at 14:45:29

Note I am running the client on a machine in Shanghai, China and the
server is in Australia so it's a little slow. The time before the
"Encryption enabled" message comes up is anywhere between 3 or 4 seconds
and 15 seconds.


cvsnt mailing list
cvsnt at cvsnt.org http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt cvsnt downloads at march-hare.com https://www.march-hare.com/cvspro/en.asp#downcvs @CVSNT on Twitter CVSNT on Facebook

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook