[cvsnt] Segmentation fault using binary deltas under Solaris 9/SPARC

r.pedroche.novillo at accenture.com r.pedroche.novillo at accenture.com
Fri Aug 31 11:40:41 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

  We are trying to use the -kB functionality in our repository for some fairly large binary files. Server is cvsnt
  There are no problems committing versions, but in some files, when checking out or updating on a branch, remote clients receive an end of file error.
  Testing directly in the server using local CVSROOT, I receive a Segmentation Fault error.
  I have compiled the sources with debug enabled and GDB points me to line cvsdelta/cvsdelta.cpp:470. I have tried to look for an error in code myself but I have forgotten almost all my C++.
  The problem happens with both the precompiled package and my on compile. Using pstack in the core generated by the precompiled version shows SIGSEGV happens in the same cvsdelta::patch function.
  I have tried copying the repository to a Windows host and using it as server and it works there on the same files extracting the same versions that fail in th Sol9 server.
Raúl Pedroche Novillo
Tel: +34 91 596 6000 ext 52576 
Accenture Outsourcing Services
ATIS/IO	 Mail/IM: r.pedroche.novillo at accenture.com	

This message is for the designated recipient only and may contain privileged, proprietary, or otherwise private information.  If you have received it in error, please notify the sender immediately and delete the original.  Any other use of the email by you is prohibited.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook