[cvsnt] Error "Up-to-date check failed for `new.txt'" even when latest revision

Thomas Singer cvsnt at smartcvs.com
Thu Feb 1 09:20:26 GMT 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I've tried GNU CVS 1.12.13 from my Ubuntu-Linux:

tom at ubuntu:~/temp$ cvs checkout test
cvs server: Updating test
U test/new.txt
cvs server: Updating test/C#
U test/C#/new2.txt
tom at ubuntu:~/temp$ cd test
tom at ubuntu:~/temp/test$ ll
total 8
drwxr-xr-x 3 tom tom 4096 2007-02-01 10:05 C#
drwxr-xr-x 2 tom tom 4096 2007-02-01 10:05 CVS
-rw-r--r-- 1 tom tom    0 2007-01-25 14:56 new.txt
tom at ubuntu:~/temp/test$ cat CVS/Entries
/new.txt/1.5/Thu Jan 25 13:56:23 2007/-kv/
tom at ubuntu:~/temp/test$ cvs update -ko new.txt
U new.txt
tom at ubuntu:~/temp/test$ cvs commit -f -m "forced to switch to -ko" new.txt
cvs server: Up-to-date check failed for `new.txt'
cvs [server aborted]: correct above errors first!
tom at ubuntu:~/temp/test$

To me it looks like a bug in CVSNT.

Best regards,
Thomas Singer
SyntEvo GmbH
Brunnfeld 11
83404 Ainring

Tony Hoyle schrieb:
> Thomas Singer wrote:
>> I've tried sending the Checkin-time-request before the Modified-request, 
>> but it still fails. :(
> No idea.. looks right to me.
> Does commit -f from a standard cvs client work?
> Tony
> _______________________________________________
> cvsnt mailing list
> cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
> http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook