[cvsnt] Cannot change permissions on temporary directory

Eric B. ebenze at hotmail.com
Fri Nov 2 03:50:02 GMT 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

>"Arthur Barrett" <arthur.barrett at march-hare.com> wrote in message 
>news:mailman.411.1193898504.24527.cvsnt at cvsnt.org...
>CVSNT is entirely file driven - it doesn't know what a project or even a
>directory is, it just recurses through the files.
>Pick a single file and try this:
>cvs co -P module/path/to/file.ext > file.ext
>Have a look at file.ext and see if you got anything, if not then:
>cvs -ttt co -P module/path/to/file.ext > file.ext 2> file-err.txt
>And sent file-err.txt to my personal address.

Hi Arthur,

Thanks for the help, but I still haven't managed to get anywhere.  Just in 
case, I tried creating a new user "Billy" belonging to the same CVS Users 
group as "Thomas".

The first co command gave me an empty file, and printed the err msg to 

So I ran the second msg with the debug level @ 3 and got the following:

  -> Tracelevel set to 3.  PID is 3032
  -> Session ID is bd8472a9d075371
  -> main loop with CVSROOT=:pserver:billy at
cvs [server aborted]: cannot change permissions on temporary directory 
D:\CVS\Temp/cvs-serv1248: Permission denied

I even increased the tracelog to level 5, but got the exact same output (the 
name of the temp dir changed)

Any ideas?



More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook