[cvsnt] Unable to access a renamed files

Alastair Hoyle ahoyle at hoylesolutions.co.uk
Mon Aug 18 16:25:58 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hi All

Firstly, this is the second time I have tried to post this message, so I 
apologise if this has been repeated, but I can't see the previous one in the 
archive so I assume it got lost some where.

I am have problems with a file that was previously renamed. Normally I use 
TortoiseCVS to do a diff on a file before committing. However when I try to 
"diff" an renamed file it fails with a "cannot find module" error. TortoiseCVS 
sends the command line

c:\program files\CVSNT\cvs.exe -d -f checkout -r 1.31 -d temp MyRepo/ExecCommands.c

So previously I have manually retrieve the older version using its previous name.

c:\program files\CVSNT\cvs.exe -d -f checkout -r 1.31 -d temp MyRepo/Command.c

This manual work around has worked fine until recently. I recently created a 
branch, I have now checked in modification to the same file in both the head and 
branch versions. When I now try to checkout any version of ExecCommands.c (the 
new name) it fails with a "cannot find module" error, as before. However, when I 
now try to manually checkout any version of Command.c (the old name) it fails 
with a "is not (any longer) pertinent" warning. It does create the "temp" 
directory but does not put any files in to it. I have tried checking out while 
in my sandbox, and in a completely clean directory, but still no file.

This means I currently have no way to retrieve my file from CVS (without 
directly access to repository). This there anything I can do?

I am currently using version CVSNT 2.5.4 Zen build 3125 RC8 both client and 
server. I am running the client and server on the same windows XP SP2 machine.
TortoriseCVS version 0.60 is installed, but I am using the command prompt for 
this work.

How does CVSNT internally rename a file? I noted the file in the repository 
still has the old name. Could I hack the repository to restore the old file name 

All help welcome
Alastair Hoyle

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook