[cvsnt] Problem branching, then error on commit in CVSNT

Andrew Cushen andrew at cushen.com
Tue May 6 22:53:09 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


[I have changed the name of the directory etc. for security etc.]

> Each sandbox has the information - 
> if you rename the repository alias you need to checkout a fresh copy - 

Things are getting really strange.

I created a new sandbox directory, and checked out the latest branch,
RELEASE_5-01-2008. That went fine. I edited stock.aspx.vb, then tried a
commit, using the same command you showed me:

cvs ci -m "test commit"

and the results:

cvs server: nothing known about `-m'
cvs server: nothing known about `test commit'
cvs server: nothing known about `--'
cvs server: Examining clientwebsite
cvs [server aborted]: correct above errors first!

It's as if CVSNT isn't recognizing an in-line commit message!

So I tried without the inline message, adding the message into Notepad when
CVSNT prompted me:

cvs ci
cvs server: nothing known about `-m'
cvs [server aborted]: Couldn't open RCS file /clientwebsite/Another test
,v: Invalid argument
cvs commit: saving log message in

"Another test commit" is the text I entered into Notepad and saved! Yet
CVSNT seems to think it's a file name!

I even tried not adding anything to the message in Notepad, just closing
Notepad. After being prompted again, I pressed "c" to continue without a log
message, and got:

cvs server: nothing known about `-m'
cvs server: nothing known about `--'

Am I losing my mind here????



More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook