[cvsnt] Problem branching, then error on commit in CVSNT

Andrew Cushen andrew at cushen.com
Wed May 7 20:59:31 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


> are you certain you used just:
> cvs ci -m ""

I actually copied and pasted the command from your e-mail, so I'm sure it's
correct. I tried again, and will send the results to the other e-mail
address (support etc.).

> I'm assuming you are just using the standard cmd.exe

Yes. Just the standard command prompt, Windows Vista on the client, Windows
XP Pro on the server.

>  You can check for a server side cvsrc

No server side cvsrc according to the command you gave me, unless I
mis-typed something:

C:\Users\Andy>cvs -d :pserver:Andy at New-P4:/clientwebsite co -p CVSROOT/cvsrc
Checking out CVSROOT/cvsrc
RCS:  /clientwebsite/CVSROOT/cvsrc,v
VERS: 1.1

However: I also took a look in the /CVSROOT directory on the server: "cvsrc"
is an empty file, but there is a "cvsrc,v". I will send that along, as well.

> A local cvsrc file can be found with:
> type %HOME%\.cvsrc

I actually get a "Windows cannot find the path" with any variation on
%HOME%. I did a Search on the client PC (Which is running Windows Vista
Business) for "*cvsrc*" and it found nothing.

At this point I should probably remind you that I was also using the PushOK
plug-in. Could that be storing the old path somewhere? I looked through all
the files in the hidden "CVS" directory that PushOK creates, and I did find
one file with the old repository path, a file named "root". I fixed it. I
still get the same results...
And I was also using WinCVS.

I'll send the new log files and the cvsrc file shortly.

Thanks again,


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook