[cvsnt] (RC9) Fail to init new repository whenaudit database enabled.

Arthur Barrett arthur.barrett at march-hare.com
Tue Nov 4 09:31:30 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hi Andy,

We cannot audit an init, and since the audit is failsafe then what you are seeing is actually the best behaviour.

I could modify the code to not crash but then it wouldn't be failsafe anymore.

If you really need to init a new repo, then first turn off audit (or just disable the audit sessionlog).

The 'real bug' is that the CVSNT control panel should check if audit is on and warn the user that it is not possible to create a new repository while audit is switched on.



-----Original Message-----
From:	cvsnt-bounces at cvsnt.org on behalf of Andy Southby
Sent:	Mon 11/3/2008 11:20 PM
To:	cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook; andysnews at southby.me.uk
Subject:	Re: [cvsnt] (RC9) Fail to init new repository whenaudit database enabled.

Hi All,

I have been using CVSNT and many versions before with MySQL
as an audit database server (Only the deltas are not being stored in the

I have just tried to add an audit database to a fresh install of the
following and I'm having difficulty.

I have also tried uninstalling (RC9) and using with success
so am puzzled (Though I know there have been changes). I am running this
on the local server as an Administrator.

1. CVSNT (RC9) Server install running on Win 2003 Server SP2
2. MySQL 5.0.67
(I have also tried Windows XP SP3 with both versions of CVSNT with the
same results. 2382 works 3229 does not).

I have created a database, user and set old_password(...)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook