[cvsnt] CVSNT 2.5.04 build 3236 server really slow [SOLVED]

jml at nykredit.dk jml at nykredit.dk
Mon Nov 24 09:19:07 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I downloaded the source files; removed the code inside the "VerifyTrust" 
function in cvsapi\win32\LibraryAccess.cpp; built the project and replaced 
the cvsapi.dll with my modified version, and - voilá - my cvs installation 
runs on full speed!

Best regards
Jørgen Møller Larsen 

"Arthur Barrett" <arthur.barrett at march-hare.com> 
12-11-2008 20:32

<jml at nykredit.dk>, <cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook>

RE: [cvsnt] CVSNT 2.5.04 build 3236 server really slow


>    You may be right, but I can't find any other executables 
> (Microsoft or
>    other) on the server that are signed, except the cvs services
>    (cvsservice and cvslock) and of course the 
> cvsnt-installer, but they
>    all start immediatly with no delay at all. Only the 
> cvs.exe processes,
>    that are "childs" of the cvsservice are delayed. The delay 
> is constant
>    and about 90 seconds per execution.

You may be seeing a diffferent problem - but the diagnostic procedure is 
the same regardless.

>    I cannot ping or nslookup the IP-address 
> (Where/what/who
>    defines which IP-address to use for the certificate 
> verification?) 

I do not get a valid reverse DNS result when trying a reverse DNS lookup 
on that IP either, though the above Verisign article clearly says it is 
valid.  You could try manually adding that address to your hosts file or 
DNS to see if it helps... 

If I try the reverse DNS using Verisigns DNS then it also does not work


But if you go to the site, it definitely looks to be the same as 

>    When running cvs.exe on the command line on the server there is NO
>    delay.

Exactly what CVSROOT - do you mean local and pserver or just one?

Have you enabled 'clients are allowed to trace server'?  Have you done a 
trace and found the point of delay?  (You may have sent this already and 
I've just forgotten...).  Have you checked cvslock deamon/service (and on 
windows cvsservice also) are running?  Have you tried stopping them and 
running them in test mode?

cvslock -test
cvsservice -test



More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook