[cvsnt] Unable to create sub-directories on a branch even with ACL set to all or read, write, create

Terry Beavers TBeavers at SkywaySoftware.com
Mon Nov 24 15:15:28 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am trying to grant a user permissions to create a sub-directories
under on a branch using the following ACL and CVS is not allowing the
operation.  I had submitted something similar in regard to creating new
files on a branch back in early October, and have since resolved that
issue, but I am still unable to create/add new directories on a branch.
Here are the parameters I am using:
The user is terry
The sub-directory is testdir
The top-level directory is releng
The CVS module is skyway
The branch is SKYWAY_BRANCH
This is the CVS chacl command syntax I am using:
cvs chacl -R -r SKYWAY_BRANCH -u terry -a all skyway/
And this is the error I am getting when I try to create/add the testdir
sub-directory under /skyway/releng
cvs [server aborted]: User 'terry' cannot create /CVS/skyway/releng
I even tried using specific perms on the specific directory, but still
no luck:
cvs chacl -R -r SKYWAY_BRANCH -u terry -a read,write,create releng/
I have also tried using rchacl, but also without success.
Additional information:
We are running CVSNT 2.5.03 Build 2382 on Windows Server 2003
The client in WinCVS (Build 1) running on Windows XP Pro
CVSROOT is :pserver:tbeavers at cvs01:/CVS
The ACLMode is set to compat (we grant all perms on this server, then
restrict as needed)
And here are a few lines from the trace log:
setting ACL for directory skyway/releng
16:32:38: S -> fileattr_create(directory)
16:32:38: S -> fileattr_read(D:/CVS/skyway/releng)
16:32:38: S -> fileattr_find(acl)
16:32:38: S -> fileattr_getvalue(@user)
16:32:38: S -> fileattr_getvalue(@branch)
16:32:38: S -> fileattr_getvalue(@merge)
16:32:38: S -> fileattr_batch_delete()
16:32:38: S -> Name_Repository((null),skyway/releng)
16:32:38: S -> map_repository(D:/CVS/skyway/releng)
16:32:38: S -> lookup_module2(skyway/releng,8047)
16:32:38: S -> Repository = D:/CVS/skyway/releng
16:32:38: S -> Mapped repository = D:/CVS/skyway/releng
16:32:38: S -> lookup_module2(skyway/releng,8048)
Any help in this matter would be gratefully appreciated.
Thanks for your support,

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook