[cvsnt] not a valid editor of the file

Arthur Barrett arthur.barrett at march-hare.com
Tue Oct 14 13:16:08 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Suman Brar,

> I am also facing similar problem. When I try to take an edit 
> for the file, cvs server refuses and shows that another user 
> has taken it for editing.

This message is from May - and the reply already includes the answer.

> cvs edit -c -- abc.txt (in directory C:\Test\)
> abc.txt	rrapplean	Thu Oct  9 21:33:59 2008 GMT	
> RRapplean	C:\cvs\
> cvs [edit aborted]: Files being edited!
> I tried using reserved edit, force edit but nothing worked. 
> Can I forcibly unedit the file from server end or do I have 
> to ask the user to explicitly unedit the file.

If you do not want this behaviour then you need to disable it by
switching exclusive (reserved) mode off.  The tool is doing what you
asked it to do.

March Hare Software pay for the permanent CVSNT and EVSCM development
team through revenues of CVS Suite - if you earn a wage whilst using
CVSNT make it clear to your employer that they should purchase several
copies today to support the project and gain some useful tools and
documentation and support.


Arthur Barrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook