No subject

Thu Oct 16 12:09:33 BST 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to

However even with the $ removed it still doesn't work but I may have
discovered why. (Unfortunately my understanding of regular expressions
is almost non existent. Soooo... complicated. They give me a head ache.)

I have switched on output to a log file in the registry and played a
hunch with the following settings.

C:\CVSNTRepos\Main\ThirdParty (Main=3DRepository, ThirdParty=3DModule)

keywords file:
   Author %a

   Author   %C

   Author   %C

When adding and subsequently commit a file called 'DefaultWrappers9.txt'
containing $Author$ in the 'ThirdParty' module/directory I obtained the
results I required. However looking at the trace [snip below] it appears
(unless I am reading it wrong) that it was the *filename* not the module
name that caused it to work.

I have subsequently tried more directory levels below the module and
find that they are all stripped prior to being passed for keywords

Am I right? Surely this must be incorrect as I don't think specifying
all the files by name would be very convenient. :)

Thanks for your help,

15:33:58: S -> default_trigger:
15:33:58: S -> Regexp match: ALL - DefaultWrappers9.txt,v
15:33:58: S -> ALL section found
15:33:58: S -> Regexp match: ^ThirdParty - DefaultWrappers9.txt,v
15:33:58: S -> Regexp match: ^DefaultWrappers - DefaultWrappers9.txt,v
15:33:58: S -> Match found!
15:33:58: S -> run keywords trigger
15:33:58: S -> run_trigger()

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook