[cvsnt] Questions and problems according moudles and modules2

Attila Strba strba at yahoo.com
Tue Sep 30 08:07:11 BST 2008


Hi Guys,

I tried also to work with the latest CVSNT client and SERVER without Tortoise but this issue still remains
Any further ideas how could I solve this problem?

thank you very much

Attila



----- Original Message ----
From: Attila Strba <strba at yahoo.com>
To: cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Sent: Friday, September 26, 2008 3:02:58 PM
Subject: Re: [cvsnt] Questions and problems according moudles and modules2

Hi Arthur, 

thanx for the good points and sorry for the lame description:

Here is more info to the problem with modules2.
1.  So the error is with modules2:

With the command:
cvs -ttt co -P CVS_TEST_DB 2> log.err > log.all

The error is following (no any other special error in Trace, tried to post the log file but it was too big, so just posting a part around the error):
cvs server: cannot open directory /PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB: No such file or directory
cvs server: skipping directory CVS_TEST_DB/SourceCode/ASICAPI_LIB

as soon as I remove the dependency it works:

#[CVS_ASICAPI_DB]
#"SourceCode/ASIC_API/HAL" = "CVS_UMODULES_DB/HAL"

[CVS_TEST_DB]
"SourceCode/ASICAPI_LIB" = "CVS_ASICAPI_DB/SourceCode/Application"


I am using TortoiseCVS latest 1.10.7, build 2382.  I tried to install latest beta server (tested with tortoise, i.e. with old cvsnt-client) but still this problem occures. 

Log file is attached.

any idea what is going wrong?

greetings

Attila

attached part of log:
CVS_TEST_DB/SourceCode/ASICAPI_LIB, /PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB, , , 0, 0)
14:12:27:  -> unlink_file(CVS/Tag)
14:12:30: S -> run template proc
14:12:30: S -> run_trigger()
14:12:30: S -> Call pre-loaded 'info.dll'
14:12:30: S -> template_proc(CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> default_trigger: parse_rcsinfo(CVSROOT/rcsinfo,CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> get_template returned failure
14:12:30: S -> open_directory(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB,(null),(null))
14:12:30: S -> RCS_parse(.directory_history,C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> rcsbuf_open(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB/.directory_history,v)
14:12:30: S -> rcsbuf_open failed
14:12:30: S -> rcsbuf_open(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB/Attic/.directory_history,v)
14:12:30: S -> rcsbuf_open failed
14:12:30: S -> No mapping file in this directory.
14:12:30: S -> fileattr_startdir(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> unlink_file(ASICAPI_LIB/CVS/Entries.Static)
14:12:27:  -> call_in_directory /PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB/,CVS_TEST_DB/SourceCode/ASICAPI_LIB/
14:12:27:  -> unlink_file(CVS/Entries.Static)
cvs server: Updating CVS_TEST_DB/SourceCode/ASICAPI_LIB
14:12:27:  -> call_in_directory /PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB/,CVS_TEST_DB/SourceCode/ASICAPI_LIB/
14:12:27:  -> unlink_file(CVS/Tag)
14:12:30: S -> Name_Repository((null),CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> map_repository(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB)
14:12:30: S -> lookup_module2(CVS_TEST_DB/SourceCode/ASICAPI_LIB,30)
14:12:30: S -> lookup_module2(CVS_ASICAPI_DB/SourceCode/Application,30)
14:12:30: S -> Repository = C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB
14:12:30: S -> Mapped repository = C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB
14:12:30: S -> lookup_module2(CVS_TEST_DB/SourceCode/ASICAPI_LIB,31)
14:12:30: S -> lookup_module2((null)(null),31)
cvs server: cannot open directory /PCSW_REST/CVS_TEST_DB/SourceCode/ASICAPI_LIB: No such file or directory
cvs server: skipping directory CVS_TEST_DB/SourceCode/ASICAPI_LIB
14:12:30: S -> fileattr_write()
14:12:30: S -> fileattr_free()
14:12:30: S -> unlink_file_dir(ASICAPI_LIB)
14:12:30: S -> close_directory()
14:12:30: S -> Name_Repository(Doxygen,CVS_TEST_DB/SourceCode/Doxygen)
14:12:30: S -> map_repository(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen)
14:12:30: S -> lookup_module2(CVS_TEST_DB/SourceCode/Doxygen,32)
14:12:30: S -> verify_access C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen,CVS_TEST_DB/SourceCode/Doxygen,(null)
14:12:30: S -> verify_perm(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen,(null),read,(null),(null))
14:12:30: S -> verify_owner(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen)
14:12:30: S -> cache_directory_permissions(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen)
14:12:30: S -> fileattr_read(C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen)
14:12:30: S -> ACL lookup on directory C:/Repository/PCSW_REST/CVS_TEST_DB/SourceCode/Doxygen
14:12:30: S -> verify_acl(read,HEAD,(null))
14:12:30: S -> user_state = 0, group_state = 0


----- Original Message ----
From: Arthur Barrett <arthur.barrett at march-hare.com>
To: Attila Strba <strba at yahoo.com>; cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
Sent: Friday, September 26, 2008 12:41:57 PM
Subject: RE: [cvsnt] Questions and problems according moudles and modules2

Attila,

> Module TEST wants to use a shared code from ASICAPI
> Module ASICAPI uses a shared code from module UMODULES. In 
> such configuration I get always an error 

Any error in particular, or just an error?

Obviously exact error message and the exact command that caused them are essential in diagnosing problems.

> modules2:
> 
> [CVS_ASICAPI_DB]
> "SourceCode/ASIC_API/HAL" = "CVS_UMODULES_DB/ASIC_Drivers/HAL"
> 
> [CVS_TEST_DB]
> "SourceCode/ASICAPI_LIB" = "CVS_ASICAPI_DB/Release/ASICAPI_LIB"

I can't think of any reason off the top of my head why that wouldn't work - but why not simplify it:

[CVS_ASICAPI_DB]
"SourceCode/ASIC_API/HAL" = "CVS_UMODULES_DB/ASIC_Drivers/HAL"

[CVS_TEST_DB]
"SourceCode/ASICAPI_LIB" = "CVS_UMODULES_DB/ASIC_Drivers/HAL/Release/ASICAPI_LIB"


> 2. It worked I was happy I thought the suffering is over. BUT 
> when now I try to tag the folder in 
> CVS_ASICAPI_DB/SourceCode/ASIC_API/HAL (which contains 
> several subdirectories) I got an error on a subdirectory on a 
> file: error file not found. But the file is there.... Any idea?

Exact command - exact error?  Does rtag work?  If you enable tracing on the server then trace it what are the last few lines of the trace?

> 3. Last question we are using 2 repositories and it is 
> possible that we need shared source code from one repository 
> to the other but neither modules2 or modules supports this. Any idea?

Merge the two repositories and use ACLs the refine access.

> I would be very glad if someone could guide me what do I do wrong.
> BTW my CVSNT version is 2.5.03 build 2382 (would it help an 
> update to the beta build)?

Any fixes would be made to 2.5.04 - please retest using the latest RC as both server and client (copy your repository to a test machine if you are not ready to make the upgrade permanent):
http://www.cvsnt.org/wiki/Download

We've always found that modules/modules2 are not as flexible as we'd like them, hence why EVSCM (previously CVSNT 3.1) has replaced them with "links".

Regards,


Arthur


      
_______________________________________________
cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs



      


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook