[cvsnt] (no subject)

Mike Kay mikekay at channelk.ca
Wed Mar 25 19:55:41 GMT 2009

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Greetings.  Thanks a lot for sending the links to your instructions.  They
are a little out of date, but helped a lot! Most excellent.

I uninstalled and reinstalled CVSNT according to your instructions. Here's
where I ran into a problem..

set cvsroot=:sspi:<computername>:/TEST
cvs passwd -a <account name>

Mine looked like this:
set cvsroot=:sspi:CVS:/test - this seemed to work.
cvs passwd -a remote1 - gave me the following error message:
cvs passwd: CVSROOT "sspi:CVS/test" must be an absolute pathname
CVS [passwd aborted]: Bad CVSROOT.

I am not on a domain.  I have a user account named remote1 on the machine.

Any suggestions most appreciated.

On Wed, 25 Mar 2009 12:41:14 -0400 (EDT), "Mike Kay"
<mikekay at channelk.ca> wrote:

>Greetings. I think I am getting somewhere - but I'm not sure.
>Here is I hope to accomplish.
>I have coders located in remote locations. They need to be able to connect
>up the the CVS server, check in code, check out code, and most importantly
>merge code. I then backup the code from the CVS server.
>My setup:
>I have a CVS server set up behind a firewall. This server is a win 2003 box.
>I have CVSNT installed on this box and a repository defined. In this
>directory is code that has been FTPd there.
>I believe I have the ports opened on both the firewall and the CVS server.
>I KNOW the CVS server port is opened. Double checking the firewall.
>So I'm trying to log in using WinCVS. Just login. I go to Admin - login.
>I click the button ...   CVSROOT is selected.
>The next dialog box opens up and I have numerous options. Here is how I'm
>Protocol - sspi
>Username/password - I have checked to make sure that the username is
>valid, the password is valid, and the user has rights to the root dir of
>the CVS. On the CVSNT machine under the Server Settings Tab I have the Run
>as user set to the same user as I am trying to log on as.
>Hostname: I am not sure what to put here.  If I enter the public IP that I
>believe I should be using, then I get the following error message:CVS
>exited normally with code 0.
>So I tried adding a new repository under the remote dropdown. I added all
>the same information for a remote repository. I get the following error
>message:Protocol error: Root request missing.
>I have tried reading the documentation - it is not oriented to Windows
>users well. I am UNDER the gun by my bosses to get this working.
>Any help - suggestions,links, or advice would be MORE than appreciated.
>If you need any more information, please let me know.
>Thank you!

Even though it is a bit outdated now, I believe that the parts after
setting up the server in my installation tips might help:


for example starting right here:


(Bo Berglund, developer in Sweden)

The highest achievement possible is compassion.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook