[cvsnt-dev] Re[2]: Next build issue on Solaris

Richard Wirth r.wirth at wirthware.de
Thu Feb 10 20:43:43 GMT 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Hello Tony,

just tried to build on solaris6 and 8.
Cause I have no extra machines I tried a cross compile.

There are some issues with solaris 6:
It doesn't have ipv6 support. So getaddrinfo() and the like are
missing. Fallback functions are in ./lib but not in ./cvsapi/lib. So
it does not build in many places.

On Solaris 8 only one error shows up:

source='../../cvsnt/protocols/library_unix.cpp' object='library_unix.o' libtool=no \
sparc-sun-solaris2.8-g++ -DHAVE_CONFIG_H -I. -I../../cvsnt/protocols -I.. -I../src  -I../../cvsnt/src -I../../cvsnt/lib  -DCVS_CONFIG_DIR=\"/etc/cvsnt\" -DCVS_LIBRARY_DIR=\"/usr/local/lib/cvsnt\"   -g -O2 -threads -c -o library_unix.o `test -f '../../cvsnt/protocols/library_unix.cpp' || echo '../../cvsnt/protocols/'`../../cvsnt/protocols/library_unix.cpp
../../cvsnt/protocols/library_unix.cpp:26:18: ltdl.h: No such file or directory

And for cross compiling there are some constructs in configure.in,
that are not working:
i.e. # Check for /usr/include/howl
and other locations where absolute path names are used

Best regards,
 Richard                            mailto:r.wirth at wirthware.de

More information about the cvsnt-dev mailing list