[cvsnt-dev] build errors on Fedora 9

Scott.J.Borton at Seagate.com Scott.J.Borton at Seagate.com
Wed Dec 3 22:02:56 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

So after I was able to build cvsnt and install it, I tried to execute a cvs
checkout command which resulted in this error:

         cvs init: connect to failed
         cvs [init aborted]: Couldn't connect to lock server

After Googling around, I found this similar Windose issue that Arthur
addressed in July of '06:


         > cvs -d C:/cvsrepos/test init
         > cvs init: connect to failed
         > cvs [init aborted]: Couldn't connect to lock server

         The lock server is not installed and not running, or your
         antivirus/firewall is preventing the connection.

         > The first I think is " I have the port 2401 closed"

         The lock service runs on port 2402 - but a "good" firewall program
         prevent a service connecting on anyway - try opening
port 2402
         just to check though.

         Otherwise it is probably that the cvslock service has not been
         automatically installed and set running in the "services" windows
         administrative control panel.

         Try this if the firewall solution did not work:
         cd C:\Archivos de programa\CVSNT\
         .\cvslock.exe -i
         net start cvslock

         Or if that fails:
         cd C:\Archivos de programa\CVSNT\
         .\cvslock.exe -test

         Then in another window:
         cd C:\Archivos de programa\CVSNT\
         .\cvs -d C:/cvsrepos/test init -a /cvsrepos-test

         Arthur Barrett

If I manually start /usr/local/bin/cvslockd and then execute the cvs cmd,
it works just fine.  So the question is how do I get cvslockd to start
automatically on boot up?  Why didn't the installation do this?  Do I have
to create my own /etc/init.d/cvslock script and the appropriate
/etc/rc.d/rc#.d/S##cvslockd link?

- sjb -
Scott Borton

             "Arthur Barrett"                                              
             <arthur.barrett at m                                             
             arch-hare.com>                                             To 
             Sent by:                  "Andreas Tscharner"                 
             cvsnt-dev-bounces         <andy at vis.ethz.ch>                  
             @cvsnt.org                                                 cc 
             No Phone Info             cvsnt-dev at cvsnt.org                 
             Available                                             Subject 
                                       Re: [cvsnt-dev] build errors on     
                                       Fedora 9                            
             12/03/2008 01:01                                              


> As far as I know, gcc-4.4 is more strict, e.g. it requires
> the include
> file to be #included where it is needed and it does not check
> if it was
> included somewhere in the other included files.
> A lot of changes that I had to make for Debian was because of this
> behavior, which gcc-4.3 started and gcc-4.4 seems to go even further.

This behaviour appears abnormal (we compile the same code with ms c++ on
windows and also aCC on HPUX after all).  Is it possible to change this
behavious with a parameter passed to gcc?  If so I'd prefer it handled
that way since we rely on included files from headers within headers all
over the code.

> That solved the problem...put the three lines at the end of
> cvsapi.h and it
> now builds and installs.  Thanks!

But I suppose this brings up the question again of why gcc 4.4 fails to
compile the code in the first place.

There is no 'harm' in 'also' adding the lines suggested (however adding
to cvsapi.h is preferable to adding to each trigger).


cvsnt-dev mailing list
cvsnt-dev at cvsnt.org

More information about the cvsnt-dev mailing list