[cvsnt-dev] Problems building CVSNT_BRANCH_2_5_03_2382

Eric B. ebenze at hotmail.com
Mon Feb 11 05:26:17 GMT 2008

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

"Arthur Barrett" <arthur.barrett at march-hare.com> wrote in message 
news:fojlu7$40m$1 at paris.nodomain.org...
> Eric,
>> Bad news is that if I try to execute some of the .exe in winrel/ 
>> directory (such as cvs.exe, rlog.exe, etc.), I get the following error 
>> msg:
>>    The procedure entry point xmlSaveToBuffer could not be located in the 
>> dynamic link library libxml2.dll.
> I Can't remember ever seeing that.  It probably means that your search 
> path is wrong - either during build or (more likely) when you exec.  ie: 
> if in build it finds libxml2.lib in /cvsbin then you need to make sure 
> that /cvsbin (or wherever libxml2.dll) is in the PATH first at runtime.

Success!  Well - kinda.  Was late at night, so can't believe I missed that 
about libxml2.dll.  I just copied it into the winrel directory, and worked 

I now have managed to compile both the 2_0_x branch and the 2_5_2382 branch, 
although the later still gives me an error msg:
 cvsnt error PRJ0019: A tool returned an error code from "Making Manifest 
And Deploying"
however, it doesn't seem to be affecting the build as the winrel/ directory 
is fully populated.

So, now comes the "kinda".  Before trying to figure out any of the merging, 
I thought I would check and see if my build (2_5_2382) worked properly. 
Indeed, I see the ctrl-panel applet give me the option for the Convert 
comments To Bug and the synonym box.  Furthermore, if I modify Change Set - 
Bug Numbers to required on Edit and Commit, CVS doesn't allow me to check 
anything in without specifying a bug number.  So far, so good.  If I use 
the -B option, my file commits properly.

However, when I try to enable the Convert comments to bug, and specify a bug 
number in my comment, CVS still doesn't accept the file.  Has 2_5_2382 been 
fully tested out and proven functional?

> cvs -ttt ci -m "log msg bug 1234" Template.class.tpl.php
00:13:40: S -> Look in the message string for a bug number (because len=16)
00:13:40: S -> The bug synonym is empty - ignoring: "".
00:13:40: S -> Use the regular expression 
00:13:40: S -> Compilation of regular expression 
00:13:40: S -> Found total result "512"
00:13:40: S -> The total result is greater than the size of the array - may 
00:13:40: S -> Search the string "log msg bug 1234" first (len=16) now
00:13:40: S -> end do_bug_msg_parse
cvs [server aborted]: Bug number is required.
00:13:41:   -> Unloading - about to clear list
00:13:41:   -> Unloading - cleared list

As you can see, the RE code seems to be triggering properly, but there is a 
problem with "Found total result '512'".  I'm having a some difficulty 
reading through the code effectively (there doesn't seem to be significant 
commenting or documentation), but from what I can tell,  commit.cpp line 
1000 ( if ((MAX_REG_RESULT+MAX_REG_RESULT_ADD)<compiled_regex.re_nsub) ) 
tests to see if the matched string is larger than the allocated array. 
Apparently, even though my entire msg is a mere 25 chars or so, it is still 
finding a 512 character match - obviously something isn't working here.

Has this convert message to bug been fully tested and proven functional?  Am 
I committing my file incorrectly?



More information about the cvsnt-dev mailing list