[cvsnt] Installing cvsnt under Redhat Linux 7.1

Gerhard Stegemann GStegemann at csi.com
Wed Aug 14 12:43:22 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I tried to install the cvsnt Redhat package under Redhat 7.1 Prof.

First rpm found some unresolved dependencies, as shown
in the following log:

  error: failed dependencies:
   /usr/local/bin/perl   is needed by cvsnt-
   no   is needed by cvsnt-
   perl(IO::File)   is needed by cvsnt-
   perl(getopts.pl)   is needed by cvsnt-
   perl(strict)   is needed by cvsnt-

When I ignored the failed dependencies I could install the
package. But trying to run the client failed, because it couldn't
connect to a server. I tried connected via pserver to a CVSNT
server running under Windows NT and also under Linux. In both
case the client just sat there and was waiting for a response.
After re-installing the cvs-1.11.1.p1 package everything is
fine again.

Running cvs-config failed due to a missing debian file called
confmodules from usr/share/debian.

My questions:

- should the cvsnt Redhat package install under Redhat or will
  it only install under Debian?

- are the perl files really needed by cvsnt for Redhat?

- is there a replacement for debian/confmodules?

- or, what tweaks are required to cvsnt running under Redhat Linux?

Gerhard Stegemann

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook