[cvsnt] remote checkout fails to complete

Paul St. John pstjohn at visible-bytes.com
Thu Dec 5 19:08:58 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> Don't open port 2402.  LockServer isn't a secure protocol & should
> only be accessed from inside the LAN.


> Probably packet loss.  I've seen this kind of thing even on Unix (If
> you've ever tried checking out code from gnu.org you'll probably see
> it).  Try some network tests and check that the remote client is
> connecting properly and can stream data from the server (try FTPing a
> large file).

Installed GuildFTPd and was able to easily transfer large files. (note:
both ends have high-speed internet connections).  We use to use cvs
in 'local' mode (please don't shout too loudly) by just doing a network
share and opening the appropriate ports.  Yes, terrible for security, 
robustness (dangling locks) and performance - but it worked until 
the ISP begain blocking those ports.

I see that the pserver protocol is documented in the installation.  I
see two approaches:

1) trace the communication between WinCvs client and Server and see 
   where the communication is breaking down (is there a facility for
   this?  In worse case I could build sources and use debug mode if
   necessary - but I'm not familiar with the code base so this would
   be time consuming).

2) try another protocol.

I'm going with two for the time being but would welcome comments and
suggestions (at least reasonably polite ones ;-)


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook