[cvsnt] RE: [cvsgui] Re: Unable to correctly import *.tar.gz archives

Bo Berglund Bo.Berglund at system3r.se
Mon Dec 16 16:09:01 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I might have misunderstood your intent here. I thought that you were going
to migrate a *repository* from Linux to CVSNT and so had tar:ed the entire 
file structure of your existing repository so as to move it over to NT.
When people do this they UnTar using WinZip and fall into the trap of "smart"
CR/LF conversion that makes the repository unusable.
Now I think that what you want is to add a *.gz file to an existing module in
the CVSNT repository. This is not what I replied to, sorry.

Well you should be able to add this file using the -kb flag in WinCvs. Just
disregard the notice about the Unicode detection, it is bogus anyway.
If you get it in to CVS as binary then it will come out as entered just fine.


-----Original Message-----
From: Arvind Raman [mailto:arvind_raman_tech at yahoo.com]
Sent: den 16 december 2002 16:45
Subject: [cvsgui] Re: Unable to correctly import *.tar.gz archives

Hi Bo and others,

This is regarding one of my previous mail. To which I
got the response attached below. Well I am not sure if
my question is really valid or not, but I would like
to know if it is not possible to import a tar.gz file
as downloaded from the ftp server directly to the CVS
When I tried doing so, 
#1. CVS first recognized the *.gz file as a Unicode
#2. The RCS file created on the database was just a
1KB in size whereas the original file was around 300KB

When the above approach didnt work, I tried unzipping
and zipping the file back as a Winzip file and then
things seemed to work perfectly well. Is this the only
way its going to work ?


So my reply from work did not appear...
Well, here goes again:
This is a FAQ: If you move a UNIX repository using TAR
and then the
TAR file is expanded in Windows using WinZip you have
to make sure the
default TAR switch in WinZip is cleared..
Go to Options/Configuration/Miscellaneous/Other
Find and clear the checkbox "TAR file smart CR/LF

then retry your expansion of the repository. My bet is
that now it
will work. You will still go over the admin files to
modify settings
that are UNIX specific.


On Wed, 11 Dec 2002 07:27:04 -0800 (PST),
arvind_raman_tech at yahoo.com
(Arvind Raman) wrote:

>I posted this query a month ago on the cvsnt mailing
>list but couldn't get any response from there.
>of fwding it here to see if anyone here could help.
>I have been facing issues trying to import *.tar.gz
>files. When I try importing these file CVS pops up a
>warning message saying that the files are being
>imported as unicode files while they are binary.
>I tried forcing these files to binary and also as
>unicode in two different experiments, but each time I
>checked out the file they were different from what
>used while importing.
>The problem goes when I extract the file from the .gz
>archive and zip them back in the winzip format.
>Is this a know problem and does there exist a
>to it ?
>I was trying to import the gawk and the sed archive
>the .gz format available from

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

------------------------ Yahoo! Groups Sponsor ---------------------~-->
Get 128 Bit SSL Encryption!

To unsubscribe from this group, send an email to:
cvsgui-unsubscribe at egroups.com


Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/ 

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook