[Cvsnt] Only "locally mounted directory" mode works ! HELP !

Koen Tanghe Koen.Tanghe at rug.ac.be
Wed Jan 30 14:27:44 GMT 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

[never done this before, so please bear with me?]

I have some problems setting up a CVS server on my Win2KPro machine.
First I tried just installing it all:
- ActivePerl (latest stable version)
- CVSNT (latetst stable version:
- TortoiseCVS (latest stable version: 0.44)
- WinCVS (latest stable version: 1.2)
Then started the CVSNT service and added a repository (OK).

Now, when using "locally mounted directory" mode, I tried creating a new
module with TortoiseCVS.

Trying to use ntserver or pserver things didn't work...
I thought: "as usual with these kind of utilities, I'll need a lot of
tweaking before things will work" and went to search for a good explanation.
So, I went to: http://www.devguy.com/fp/cfgmgmt/cvs/
and followed the instructions (using pserver method, because also Linux
machines need to connect to the CVS server). I also followed the passwd
approach, since domain passwords appear to be easily cracked.
After an hour or so (double checking all steps), it still doesn't work: it
keeps telling me that my "testuser" is not a valid user:

*** start of TortoiseCVS log ***
In E:\Documents and Settings\ktanghe\Desktop: cvs -q -z6 checkout
cvs checkout: authorization failed: server argon.rug.ac.be rejected access
cvs checkout: used empty password; try "cvs login" with a real password

Error, CVS operation failed

In E:\Documents and Settings\ktanghe\Desktop: cvs -q -z6 login
(Logging in to testuser at argon.rug.ac.be)

Success, CVS operation completed

In E:\Documents and Settings\ktanghe\Desktop: cvs -q -z6 checkout
Fatal error, aborting.
testuser: no such user
cvs checkout: authorization failed: server argon.rug.ac.be rejected access

Error, CVS operation failed

Tortoise Tip:  Sometimes login can fail if you have the repository directory
wrong in the Checkout dialog.  Make sure you have a slash at the start of
directory, and that the case and path are correct.

Examples are:  "/cvsroot", "/usr/local/cvs-repository", "/cvsroot/cvsgui"
*** end of log ***

Any clear explanation of how to simply setup a CVS server on a Win2K
machine, using authentication, and available from Win2K and Linux machines?


Cvsnt mailing list
Cvsnt at cvsnt.org
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook