[Cvsnt] pserver: server rejected access to repository

Wolfgang Auer wolfgang.auer at fh-vorarlberg.ac.at
Fri Jul 19 11:07:15 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


There has been a lot of post concerning pserver access for CVS. Although I
tried all the suggestions I am still not able to connect to my repository
using pserver

My actual situation:
* I'm running Win2k, SP 2 using CVS for Win (Build 57f)

* My registry looks like this:

* I created a passwd file for user aw using htpasswd.exe. Afterwards I
copied this file to c:\repository\CVSROOT
* I added the CVS program directory to my path environment variable
* I created the CVSROOT environment variable referring to C:\repository
* I am using NTFS but didn't set any special file permissions for the
repository directory

If I try to login to the repository CVS reports an authorization failure!
C:\>cvs -d :pserver:aw at localhost:c:/repository login
Logging in to :pserver:aw at localhost:2401c:/repository
CVS password: ***
cvs [login aborted]: authorization failed: server localhost rejected access
to c:/repository for user aw

Did I forget something?

Best regards,

Cvsnt mailing list
Cvsnt at cvsnt.org
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook