[Cvsnt] RE: ViewCVS

Mehling, Ben ben at gsm.uci.edu
Fri Jun 14 17:34:54 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> Message: 15
> From: "Jones, David G" <DavidG.Jones at gbr.xerox.com>
> To: "Cvsnt (E-mail)" <cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook>
> Date: Fri, 14 Jun 2002 15:31:10 +0100
> Subject: [Cvsnt] ViewCVS
> Hi, I noticed a little while back that some people had managed to get
ViewCVS running on windows >
> using the version from http://russ.hn.org/viewcvs/ and I was hoping
for some help.


> AttributeError: 'NoneType' object has no attribute 'split'
> Does anyone know what's wrong - it looks like a library is missing/has
changed.  I'm running with
> ActivePython 2.2.1 (should I have the version from Python.org?) on
Apache and NT4

Having just installed the viewCVS-1.0-DEV dist available on that site
yesterday, I can say that it works fairly well.

The error you are quoting appears to be a python error, and other
non-viewCVS scripts generate the same error:

Perhaps your script mapping is incorrect in apache, or you need a final
"/" on the end of your URL.  I've included my install notes below if
that helps, although I'm currently using viewCVS with IIS5.  Sorry for
the lengthy message.

> Also, which way should the slashes go in file paths in the .conf file
on Win32 (or does it not > >
> matter)?

I tried to be consistent and use forward slashes everywhere:

- Ben

Grab latest versions of various utils:

- Activestate python 2.x
- you'll need the cvs/rcs tools (duh. :)

- viewCVS-1.0-Dev for win32: http://russ.hn.org/viewcvs/
  - enscript -- I had to install the complete dir tree from:
                     And the compiled binary from:

                     The first got installed into c:/progra~1/enscript/,

                     while the later requires the .cfg file to be in
                     The escript.cfg file needs to be modified to the
correct system specific paths
     - sed, from: http://gnuwin32.sourceforge.net/, installed in
     - I don't think you need: gettext or libiconv. (from:
http://gnuwin32.sourceforge.net/) when using the binary of enscript from
  - cvsgraph (graph application): used included binary from viewcvs dist
                    copied into c:/services/cvs -- cvsgraph.exe,
libjpeg.6.dll, libpng.2.1.dll, and libz.dll

- Setup IIS to point to the appropriate root (where I installed the
viewcvs tree)
- Mapped .cgi to python (' c:/services/python22/python.exe "%s" ')
- added viewcvs.cgi as a default doc

In viewcvs.conf:
- enabled enscript, set path
- enabled gzip
- enabled cvsgraph
- set paths
- set fonts

Cvsnt mailing list
Cvsnt at cvsnt.org
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook