[cvsnt] Re: Setting locking to strict

Oliver Giesen ogware at gmx.net
Thu Sep 5 16:36:14 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

> I'm new to CVSNT and installed version I would like to know if I
> can
> configure CVSNT for managing reserved checkout for the whole projects
> repository.
> The CVSNT documentation indicates to use the command "cvs admin -L".
> But when I tried to execute it, I obtain the message:
> > cvsadmin: in directory .:
> > cvs [admin aborted] : *PANIC* administration files missing
> The command I entered is :
> > C:/cvs/cvs.exe -d c:/CvsRepo/projects admin -L
> where "projects" package contains all projects archived including the
> CVSROOT folder.
> Note also that I tried the command while the NT service was running.
> If I do a mistake, could someone help me and tell me the correct step by
> step procedure ?
> Or is it a CVSNT bug ?

First of all: reserved checkouts (aka locking) are deprecated since CVS
1.11.x (IIRC). Thus, even if you managed to execute cvs admin -L you would
get an error message when you tried to actually lock a file. Instead you're
encouraged to use "reserved edits/commits". You could do a search on the web
and/or this list about how to use this.

Next: Strict locking would be the default for a CVS repository anyway. You
don't have to set it unless you explicitly set locking to non-strict before.
This is also in the docs (Cederqvist).

Then: What are you running the server (aka cvsservice.exe) for? The way you
quoted your command you are accessing your repository in local mode, IOW you
bypass the server completely. If you really want to make use of your server
(and you should - assuming that you want to access that repository with
multiple developers - why else should you want to use locking in the first
place) and when using the -d option, your CVSROOT string should look like


(alternatively use :sspi: instead of :ntserver:)

Instead of specifying it via the -d option you could also simply declare an
environment variable named CVSROOT which holds that string.

You will also have to add that CVSROOT in the CVSNT control panel applet too
(requires restarting the service) if you haven't done so already.

Furthermore: most CVS commands require to be executed from within a sandbox,
i.e. the current working directory should have a subdirectory named CVS with
some administrative files in it (you do not need to create this manually -
CVS takes care of this when running checkout or update).

In general I suggest, you read a bit of this:
http://cvsbook.red-bean.com/cvsbook.html (attention: huge document! ~900k).

Hope this helps.

JID: ogiesen at jabber.org
ICQ: 18777742
Y! : ogiesen

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook