[cvsnt] Problem adding users

Chad Myers cmyers at N0.SP.4M.austin.rr.com
Sun Sep 22 04:41:37 BST 2002


My CVS repository root is c:\cvs

I have a module called forums

I'm having this same problem, so I create:

c:\cvs\CVSROOT\admin

and add my username "chad" to the first line with no trailing spaces
or CR/LF.

I restart the CVSNT service.

I open a cmd prompt and type:

set cvsroot=:ntserver:SUCKA:/forums
   (SUCKA is my servername, long story...)
cvs passwd -a chad
(password verification stuff)

Then it says "Only administrators can add users"

Do I need to put DOMAIN\Chad in the 'admin' file?

What am I missing?

Thanks,
Chad

"Bo Berglund" <bo.berglund at telia.com> wrote in message
news:74s4nucsjn1ihlmmnn4hijc65t05r3egb7 at 4ax.com...
> It has been reported that the membership of admin or domain admin
> groups sometimes do not pass through to CVSNT. There may be case
> sensitivity in the spelling of both or only the login name.
> Anywy, adding a new file CVSROOT/admin and adding your login to that
> file on a single line will probably allow you to be accepted as an
> admin. I tested this yetserday on a domain connected CVSNT server and
> it worked right away:
> First I was not allowed like you even though I am an admin on the
> local server. Then I added the admin file and for safety restarted
> cvsnt. After this I was allowed to add users...
>
> /Bo
>
> On Fri, 30 Aug 2002 12:19:17 -0700, "Zazueta, Robert"
> <RZazueta at academyart.edu> wrote:
>
> >OK, I received a suggestion that said this may have something to do with
me
> >not having local admin rights, but I have local admin rights. So, still
> >stuck on step nine on Win2k. I try to run this command:
> >
> > cvs passwd -a AAC/rzazueta
> >
> >Which is my domain and username. I enter the password stuff as prompted,
but
> >am still greeted by a message telling me that:
> >
> > cvs [server aborted]: Only administrator can add or change another's
> >
> >Again, I'm an admin on my domain AND the local box. Any ideas?
> >
> >Thanks!
> >
> >Rob Z.
> >
> >-----Original Message-----
> >From: Zazueta, Robert [mailto:RZazueta at academyart.edu]
> >Sent: Thursday, August 29, 2002 11:10 AM
> >To: 'cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook'
> >Subject: [cvsnt] Problem adding users
> >
> >
> >I've installed CVSNT on a box running Win2K with SP3 and followed all
ofthe
> >steps verbatim through to Step 9. It's here that I'm experiencing a
problem.
> >I try to add myself tot he passwd list using the ntserver protocol as
> >suggested using my local box name (NOT localhost). I've tried to add
myself
> >using my NT user name using both the normal username and domain/username
> >formats. Here's the command I've used:
> >
> > c:\ set cvsroot=:ntserver:robsbox:/test
> > c:\ cvs passwd -a domain/rzazueta
> >
> >Also tried:
> >
> > c:\ cvs passwd -a rzazueta
> >
> >In both cases, after entering a password twice, I get the following
response
> >from CVS:
> >
> > cvs [server aborted]: Only administrator can add or change another's
> >password.
> >
> >Now, I know that I'm an administrator on my machine and to my domain,
though
> >I believe there may be some restrictions (no idea what they are, but I
can't
> >run the event viewer on my machine due to "policy restrictions"). I was
able
> >to checkout CVSROOT and added an admin file there listing my username
sans
> >domain and checked it back in without hassle. This did not fix the
problem.
> >
> >Any ideas?
> >
> >Thanks!
> >
> >Rob Z.
> >
> >_______________________________________________
> >cvsnt mailing list
> >cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
> >http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs
>
>
> /Bo
> (Bo Berglund, developer in Sweden)





More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook