[cvsnt] Re: Crash on socket connect

Timo Kauppinen timo.kauppinen at lut.fi
Tue Sep 24 20:04:52 BST 2002

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

"Tony Hoyle" <tmh at nodomain.org> wrote in message
news:3d90a643.108901171 at news.cvsnt.org...
> On Tue, 24 Sep 2002 20:29:05 +0300, "Timo Kauppinen"
> <timo.kauppinen at lut.fi> wrote:
> >At the moment there's no other option than re-installing the whole
> >
> >Before that I'd like to try anything else.. It shouldn't be too difficult
> >track down the problem since it's happening so soon in the execution. No
> >repositories are read at that point, I guess.
> >
> >In fact the service has been crashes once or twice earlier (long long
> >ago), and for that reason I'd like to see also a debug version of the
> >cvsservice..
> >
> If you have a compiler then it might be worth running in debug just to
> see if there's anything that can be trapped in the future.  Also try
> different protocols since they have different codepaths, etc.
> :ntserver: is totally different (since it doesn't even use a socket).
> :pserver: is the most volatile as it's vulnerable to changes on the
> domain controller, although it shouldn't crash.

Perhaps I'm not using VC debugger correctly but it didn't reveal much more
information. Just the null-pointer exception described earlier.

I tried also :ntserver it worked fine at least when running "cvs -d
:ntserver:server:/CVS ls". But sspi crashed, as well. Unfortunatelly, I need
to make also sockets working in one way or another..


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook