[cvsnt] New fields in CVSNT Repo file confuse ViewCVS

Paul Russell paul_newsgroups at yahoo.ca
Mon Jan 6 00:11:33 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I tried changing the repository root in the viewcvs.conf file as you suggested: 
from: d:\cvsserver\cvsrepo\wrk 
to:    \ \servername\d$\cvsserver\cvsrepo\wrk 
But now I get an error where python can't find the files, even though I can browse the same path with Internet Explorer (I tried using the IP instead of the server name as well). Any Suggestions? 
We're using: Win2000 SP3 with IIS, cvsnt_1.11.1.3.exe 64, rcs57nt.zip, ActivePython-2.2.1-222.msi, viewcvs-1.0.dev-win-r2.zip 
(The \\ can cause HTML based EMail programs to change the output, so I put a space between them in this email)

((((ViewCVS/Python Error: ExceptionViewCVS Messages:

\ \server1\d$\cvs_server\cvsrepo\cvs_wrk\ not found!The server on which the CVS tree lives is probably down. Please try again in a few minutes.

Python Messages:

Traceback (most recent call last):  File "d:\cvs_server\ViewCVS\lib/viewcvs.py", line 2667, in main    raise debug.ViewcvsException('%s not found!\nThe server on which the CVS tree lives is 'ViewcvsException: ViewCVS Unrecoverable Error))))

-Paul Russell

 Phil Dye <phil.dye at alchemydigital.com> wrote: 
"Tony Hoyle" wrote in message
news:auepop$b1l$1 at sisko.nodomain.org...
> ViewCVS - the new fields are valid within the existing RCS specification
> (see 'man rcsfile'), and ViewCVS should just be ignoring them if it
> use them, just like older versions of CVS do.

I had similar symptoms (tracebacks within ViewCVS, reporting problems with
unknown error messages from rlog (from memory)).

It turned out it wasn't actually a problem with the RCS fields output by
rlog at all (ViewCVS has code to handle that already) - it was acutally
because I had set the repository root to be "<driveletter>:\path\to\repository", and the extra colon was breaking it. I changed it to it to \ \<servername\<driveletter>$\path\to\repository and it's been fine since.


Phil Dye, Technical Services Manager
Tel: +44 (0)23 8021 3400

cvsnt mailing list
cvsnt at cvsnt.org cvsnt downloads at march-hare.com @CVSNT on Twitter CVSNT on Facebook
http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt https://www.march-hare.com/cvspro/en.asp#downcvs

Post your free ad now! Yahoo! Canada Personals
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.cvsnt.org/pipermail/cvsnt/attachments/20030105/df364031/attachment.htm 

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook