[cvsnt] Problems rebuilding the adminstrative database

James Walker James.Walker at StockSoftware.com.au
Wed Jan 8 22:22:41 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I have recently aquired a problem when re-building the adminstrative
database under CVSNT (Build 57c)

It had worked for quite some time and then suddenly started failing with
errors like:
    Checking in loginfo;
    e:/iris_cvs/CVSROOT/loginfo,v  <--  loginfo
    new revision: 1.12; previous revision: 1.11
    cvs server: Rebuilding administrative file database
    cvs server: cannot rename loginfo to .#loginfo: Permission denied
    cvs server: cannot rename .#544 to loginfo: File exists

I don't have to check in loginfo to get it to produce the error for
loginfo - if I check in other CVSROOT files it gives the same errors.  The
only variance is in the #544.

Any hints on how I might be able to get this working again?  I've tried
restarting the service and rebooting the server, I've verified (I believe)
that the files and CVSROOT directorty are editable by everyone.

I believe this started after we had a failure in comms between a client and
the server but that could be heresay.

James Walker
Stock Software

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook