[cvsnt] pserver not working

Scott.Warnick at flyingj.com Scott.Warnick at flyingj.com
Wed Jul 16 23:06:35 BST 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am struggling with the pserver protocol. I am working with Windows 2003
standard edition as a host for CVSNT, and with a mixture of Windows XP,
NCR Unix, HP-UX and Linux clients.  The CVSNT control panel reports that I
am using CVSNT 2.0.6.

With SystemAuth=yes in the config file, everything works fine. I can
checkout, commit, list, etc. from both Windows and Unix clients.  However,
when I take the advice of the installation guides and use a local passwork
file instead using domain passwords. The manuals I am referring to are
When I set SystemAuth=no to avoid having to store lightly-encrypted domain
passwords and sending domain passwords as clear text, I start having

First, the manual says to use ntserver to set the password for the very
first user. When I try
     set cvsroot=:ntserver:<computer name>:/main
and then
    cvs passwd -a swarnick
cvs reports that "the ntserver access method is not installed on this
It says this even though I check ntserver on the advanced tab of the
service configuration dialog box.

I tried to get past the difficulty by setting the protocol to sspi just to
get the password file initialized
set cvsroot=:sspi:<swarnick>:/main
cvs passwd -a swarnick
CVS password: ***********
confirm password: ***********

This works, and creates a local password file with an entry in it for
myself as new user. However, when I try to set the protocol back to pserver
to use the new entry in the password file, I get an impersonation failure
when I try to log on.

cvs login swarnick
CVS password:************
Fatal error, aborting
cvs [logon aborted] Impersonation failed - configuration error. Contact
your system administrator.

I tried adding a local user swarnick and making that user a member of the
administrator's group for the machine. I also checked file  permissions and
for myself as a user and tried to give the SYSTEM user the right to create
a token object. No luck--I am still getting the same error.

I have to get pserver working for all of those unix clients. so I am hoping
for a helpful reply.


I notice that this question has been posted previously with no reply.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook