[cvsnt] Problem with post-commit update script off wiki

Samuel Neff sam at serndesign.com
Wed Nov 5 21:05:45 GMT 2003

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


Sorry about that--I meant to reply to the group; just forgot reply by itself
doesn't work in this list.

Removing start gave me a return code of 256.  I have no idea what this

Added /wait cause it to stop working entirely (even interactively).

I tried adding an output redirect like this:

my $args = "start cmd \/c \"cd \/D $dir \&\& cvs.exe -d :local:$CVSROOT
update -dP >e:\\temp\\post_commit_copy.txt \"";

and while the post_commit_copy.txt file does get created, it's always empty
(even when run interactively).  I guess I can't redirect cvsnt output.  In
any case, the file does get created when run by the post-commit thing, so I
guess the command is definitely running to some extend, just not sure why
it's not updating.

If I change the command entirely to this:

my $args = "start cmd \/c \"echo hmm >e:\\temp\\post_commit_copy.txt \"";

it creates the text file as expected.  So it's just running cvs from the
post-commit that doesn't work.

I'm really stumped here.  :(


> -----Original Message-----
> From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org]On Behalf
> Of Glen Starrett
> Sent: Wednesday, November 05, 2003 3:44 PM
> To: 'Samuel Neff'; 'CVSNT'
> Subject: RE: [cvsnt] Problem with post-commit update script off wiki
> > Hadn't thought of that, but just checked.  The path setting is system
> > wide--not only on current user.  I tried changing the perl
> > script to have a
> > fully qualified path anyways and also tried setting the path
> > in the perl
> > script.  Still no work.
> Always copy the list on a reply, since others may have better ideas than I
> do... Which in this case I hope it holds true since I'm out of
> ideas on this
> one.
> Stab in the dark:  Either remove start or call start /wait instead since
> start alone is asynchronous (I think) and always returns 0 in that case.
> Regards,
> Glen Starrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook