Socket failure (was "Re: [cvsnt] 2.0.26 on XP Pro -")

Damien McKenna damien at
Sat Feb 21 01:35:16 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to

Richard Wirth wrote:
> M> cvs server: Error connecting to host localhost: No such host is known.
> It's already telling you, what's wrong!

It is, but localhost does exist.  That's where the nonundrum is.

> What about a 'ping localhost'?

C:\Documents and Settings\Damien McKenna>ping localhost

Pinging Damiens [] with 32 bytes of data:

Reply from bytes=32 time<1ms TTL=128
Reply from bytes=32 time<1ms TTL=128


> did you install the loopback adapter?


> is localhost in your etc/hosts?


Glen Starrett wrote:
> A shot in the dark:  what's your d:\cvs\mine\cvsroot\config file look
> like? Mine is all comments, except for SystemAuth=yes.


> My system is set up (control panel) to use lockserver on localhost port
> 2402--and it sounds like yours is too.


> Are you running CVS and CVS Lock service under the default SYSTEM
> account or another?

I haven't veered from the default configuration, so they would be running as

> Any interesting items in your event log?

Nope, it just gives a mention of when the services start and stop.

> The socket thing is normal, it's gserver looking for an AD domain but
> not finding it, so it's OK (you just can't use kerberos).

That's nice to know, one marked off the check list.

One thing that I _did_ see, in the ZoneAlarm log, was that the CVS command
hit the DNS server in my router, which it shouldn't have needed to do to
access localhost?  I don't know if it was doing that while doing the
connection to the cvsservice or cvslock.

Has anyone noticed conflicts with other software, eg InCD, DaemonTools, etc?
  I'll do some more testing over the weekend...

Another thing I tried was I attempted to import some files into a new module. 
   It worked.  I verified that the files are actually in the repository.


Ok.  I upgraded to 2.0.30, did the same thing (tried checkout out a module) 
and this time it crashed! :-)  I saved out the debug info and I'll wing it 
away to the powers that be.  At last something solid to go on!
Damien McKenna - damien at -

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook