[cvsnt] Absolute newbie: Cannot agree on an authentication scheme (got '')

jamief at fcl-us.net jamief at fcl-us.net
Thu Jan 22 00:56:09 GMT 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am getting the same error message. I'm using windows 2000 pro and i'm on a
comcast cable modem, so there is a firewall. I've tried manually enabling
ports 2401-2402, but that did not solve the problem. I' have all the
protocols installed, but i am setting it to use sspi. even when i do a "cvs
ver" I get this "cannot agree on authentication scheme".
I've succesfully installed it at work on my XP machine, but that also has a
different kind of firewall.
Anybody using sspi succesfully on a cable modem?

"Bo Berglund" <bo.berglund at telia.com> wrote in message
news:5c5ivvsv8q37gn21ou1ra6c48pq7uoi38c at 4ax.com...
> On Mon, 5 Jan 2004 03:16:15 -0000, Bjørn Toft Madsen
> <sunbeam60 at sunbeam60.net> wrote:
> >Accordingly I figured I would alias some user names to get onto the
> >
> >However I get the following output:
> >------------------------------------
> >F:\>cvs passwd -a -r "Bjørn Toft Madsen" bjorn
> >cvs [passwd aborted]: Can't authenticate - server and client cannot agree
> >an authentication scheme (got '')
> >------------------------------------
> >
> >... and even if I try to set up a regular user (myself) using...
> >------------------------------------
> >F:\>cvs passwd -r "Bjørn Toft Madsen" -a "bjorn"
> >------------------------------------
> >
> >... I get the exact same response. Was looking through the mailing list
> >archive, but could only find
> >http://www.cvsnt.org/pipermail/cvsnt/2003-October/009048.html which
> >really provide any clues.
> >
> 1. If you want to use users from the passwd file then they will have
> to use the :pserver: protocol. But I guess you knew this already.
> 2. I tested on my system by adding a real user account named "kalle
> kula" and then issuing the commands like this:
> C:\Temp>cvs passwd -a oscar -r "kalle kula"
> Usage: cvs passwd [-a] [-x] [-X] [-r real_user] [-R] [-D domain]
> [username]
>         -a      Add user
>         -x      Disable user
>         -X      Delete user
>         -r      Alias username to real system user
>         -R      Remove alias to real system user
>         -D      Use domain password
> C:\Temp>cvs passwd -r "kalle kula" -a oscar
> Adding user oscar at altair
> New password: *****
> Verify password: *****
> As you can see the order of the added and real user seems important,
> by first specifying the real user and then the cvs user it worked.
> However, I did not get the same error message as you did and I did not
> use an "exotic" character in the username either....
> 3. Check the cvs version by this command:
> C:\Temp>cvs ver
> Client: Concurrent Versions System (CVSNT) 2.0.11 (client/server)
> Server: Concurrent Versions System (CVSNT) 2.0.11 (client/server)
> What do you see? Can you execute any cvs command at all?
> Like cvs ls for example...
> /Bo
> (Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook