[cvsnt] 2.0.51 windows clien - problems:

Tony Hoyle tmh at nodomain.org
Thu Jul 29 16:35:34 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Harrison, Andrew wrote:

 > I've tried setting the permissions correctly and forcing a commit, but
 > it's still wrong when I do an update. I assume this is because my server
 > is still 2.0.41?

No, that'll work unless you have the repository on a FAT drive.

I'd normally use chmod, but I just tried editing the ACL directly and it 
picked it up quite nicely.

I've never come across the idea of windows itself obeying execute until 
recently.  By default it has a nice collection of ACLs on the root drive 
that effectively grant execute to everyone, and only an explicit deny 
will stop it (sometimes not even then)...  It seems some are now locking 
down their roots to deny execute which is why I've not heard of any 
problems (this code has been active since April with no issues).  If you 
re-add the default ACLs to the root drive it'll work too without any 
extra effort.


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook