[cvsnt] Re: problem with checkout / permissions?

Gerhard Fiedler lists at connectionbrazil.com
Sat May 29 21:25:46 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

>> FWIW, after I went back to my previous version (2.0.13) on the server, it
>> worked again. So in between it seems something broke -- or I have a
>> configuration problem that worked with 2.0.13 and not with 2.0.41a.
> There isn't much to go wrong... the code is literally just a string 
> compare with the current directory and the CVSROOT.  I can only guess 
> that something is causing them to be the same in your configuration, and 
> that wasn't caught in 2.0.13.

Maybe I have time to look at the code itself, but I think that there's
something missing here. FWIW, 2.0.34 works, and 2.0.35, 36, 38 and 40a
don't. From what I've seen by a cursory browse, it seems that some code to
fake a Unix server has been added or modified from 34 to 35.

I'm checking out from a remote system, not on the server itself, onto a
local disk on that remote system. From this alone, it doesn't make sense
for the server to tell me that it "cannot check out files into the
repository itself". There is no repository on the system I'm using for
checking out. The repository on the server is in a path
E:\Data\CVS\repositories\..., and I'm checking out on a different system to
E:\Test\user. I tried also F:\Test\user. If the code considers that
checkout directory the same as the repository directory, there is probably
a problem in the code... :)

In the manual it says about this: "The obvious cause for this message
(especially for non-client/server cvsnt) is that the cvsnt root is, for
example, /usr/local/cvsroot and you try to check out files when you are in
a subdirectory, such as /usr/local/cvsroot/test."

Since I am on a different system, I cannot easily be in a subdirectory of
the repository root.

"However, there is a more subtle cause, which is that the temporary
directory on the server is set to a subdirectory of the root (which is also
not allowed)."

I don't know exactly what the CVSNT server uses as temp directory. If it is
using the value that's configured through the configuration applet (which
would be what I expect), that's E:\Data\CVS\tmp. This is not a subdirectory
of a repository root (the repository prefix is "E:/Data/CVS/repositories").
To make sure, I changed the temp dir setting to F:\tmp\CVSNT -- no change,
same problem.

"If this is the problem, set the temporary directory to somewhere else, for
example /var/tmp; see TMPDIR in Appendix D, All environment variables which
affect CVS , for how to set the temporary directory."

The users I am using to connect to CVS don't really connect to the server
directly, so they don't seem to have an environment set up there. I don't
know what their TMP and TEMP environment variables look like in the cases
where they never logged in, but I suppose nothing like
E:\Data\CVS\repositories\ (my repository prefix). There is no TMPDIR
environment variable on this server.

To make sure, I logged in as one of them and verified the TMP and TEMP
environment variables. Sure enough, they are as expected ("C:\Documents and
Settings\user\Local Settings\Temp"). This is also not a subdirectory of the
repository, and having logged in once on the server as that user didn't
solve the problem either.

So I really can't see what should be wrong with my configuration. How can
CVSNT think I'm trying to check out into the repository itself when I am on
a remote system, checking out to a local drive?

What else could I do to try to work around this?


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook