[cvsnt] Error with 2.0.51d ends with "results may not be correct"

Gates, Donald T. DONALD.T.GATES at saic.com
Fri Sep 3 01:29:55 BST 2004

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I just ran into this problem (which Tony, Glenn, and Fish have already
solved in a previous posting) and implemented the recommended solution (and
it worked - of course).

However, it bothers me that I must grant read and list access to all the
directories (from the root of the drive volume) all the way down to the CVS
repository's directory. This seems wrong to me. I don't want my users to
have the ability to traverse these directories.

Why can't the CVSNT server process use its rights (as SYSTEM, I assume) to
traverse the intervening directories (from the volume's root down to the CVS
repository's directory) and THEN examine the user's ACL to see if they have
rights to the module they are trying to access? (In a sense, isn't this the
same as the "virtualized" path to the repository's root that Tony
implemented some years ago?) 

Donald T. Gates

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook