[cvsnt] Notify on edit and commit don't work properly

Дмитрий Жилин zhilindy at mail.ru
Wed Aug 3 05:18:05 BST 2005

I have encountered the following problem:notify script don't run after cvs edit command .Postcommand script fires OK,but we'd like to notify editors and watchers on edit done by somebody else.The unedit command executes notify script without problems.There is another bug:message specified on commit (%m in notify script) seems to be empty calling notify program(CVSROOT/notify administrative file).The unedit command passes all arguments OK.The -a option of edit command don't work at all:Watches established on edit always are the same: tedit , tunedit , tcommit.The file CVS/fileattr.xml after "edit" always contains tags tedit , tunedit , tcommit whether "-a none" option specified on "edit" command or not.
We tested client and server from builds and under Windows XP and 2000 - problems are the same.Configuration of both client and server was default (Complete install).
I can't tell this problems resides on client or server side:some old clients (version ) connected to the same new server (version 2.5.01) send notifications on edit well.

There is trace on edit command 
08:56:42:   -> Tracelevel set to 1.  PID is 3040
08:56:42:   -> Session ID is be042f0407a49e4
08:56:42:   -> Session time is Wed Aug  3 03:56:42 2005
08:56:42:   -> main loop with CVSROOT=:pserver:@pr-zhilin:/CVS
08:56:43:   -> Server codepage is CP1251
08:56:43:   -> Client codepage is CP1251
08:56:43:   -> Server version is CVSNT 2.5.01 (Travis) Build 1976
08:56:43:   -> Client version is CVSNT 2.5.01 (Travis) Build 1976
08:56:43:   -> Requesting server cvsignore
08:56:43:   -> Requesting server cvswrappers
08:56:43:   -> Requesting server cvsrc (read-cvsrc2)
08:56:43: S -> run_trigger()
08:56:43: S -> Call pre-loaded 'default_trigger'
08:56:43: S -> precommand_proc()
08:56:43: S -> Checking admin file D:/CVSRepository/CVSROOT/admin for user ZhilinDYa
F1.TXT  FadeevaOV       Mon Aug  1 08:54:49 2005 GMT    pr-zhilin       D:\TEMP\w\w
08:56:43: S -> run_trigger()
08:56:43: S -> Call pre-loaded 'default_trigger'
08:56:43: S -> postcommand_proc()

I hope this problems will be fixed in next releases.
Best regards,
Dmitry Zhilin,Russia.

More information about the cvsnt mailing list