[cvsnt] Re: More on authentication problems with build 2048 and up...

Bo Berglund bo.berglund at telia.com
Fri Aug 12 23:51:28 BST 2005

On Fri, 12 Aug 2005 23:04:55 +0100, Tony Hoyle
<tony.hoyle at march-hare.com> wrote:

>Bo Berglund wrote:
>> I have now tested against two different servers, one running 2.0.38
>> and the other using 2.0.41 (my development server with CVSMailer
>Can you repeat against 2.0.58 or something newer?  I suspect a bug in 
>those older servers, since it isn't a problem for me at all.

In order to get such a server up I uninstalled the latest build from
my development machine and then installed 2.0.58d.

I don't know if this is a valid test but when using this combination I
am not anymore getting these errors.

Client: Concurrent Versions System (CVSNT) 2.5.02 (Servalan) Build
2054 (Release Candidate 3) (client/server)
Server: Concurrent Versions System (CVSNT) 2.0.58d (client/server)

So it seems to be a case of a combination between the age of the
server and the client. Client build 2040 and any server or any client
and 2.0.58 or later server.

Sad, because up until build 2040 it was still possible to use the
newest CVSNT as client to any server, but now it seems that the newer
builds limit the range of possible servers to 2.0.58 and later only.

And I can't update the production servers just yet, for example
2.0.58d breaks the taginfo handling, which is no good for our email
records of the activity.


(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list