[cvsnt] why "cvs crown cvsuser" gimme FAIL LOCK not in repository?

hiiyan hiiyan at yahoo.com
Fri Jul 15 12:29:54 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Dear all,

I have tried many ways to use cvs chacl to set ACL for the different user 
groups on folders but seem to hit error every way.

I am using CVSNT 2.5.01 (Travis) Build 1976 on WinXP Pro.

I want to control the access on the subfolders. Let say, group1 only able to 
commit and see folder1. Group2 for folder2. And Group1 cannot see and commit 

There are so many ways and I actually don't know which way is for the cvsnt 
version that I am using.

I did try to create real user groups on the WinXP. then use cvs passwd to 
create and add virtual user to the group.
Then I went to the particular folder in the repository and change the 
Security setting. This cannot work coz as long as there is Administrator, 
all the virtual users can access that folder. So I guess this method is 
incorrect. (I logged in as Administrator)

Then, I tried the cvs chacl. I got error "no version found. do cvs 
checkout..". I went to do cvs checkout. This command ran with no problem but 
I still get "no version found" error with cvs chacl. (will empty folders 
cause problem?)

Then I tried another method which I got from this newsgroup to use cvs crown 
but this time I got "../.directory_history,v.FAIL Lock not in the 

sigh.. i really can't make this ACL work :(
Pls help me. This is my first time setting up this kind of access control.

Thank you so much


More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook