[cvsnt] Re: Browsing CVSNT using extssh

Mark Townsend mtownsen at nowhere.com
Fri Oct 7 18:26:31 BST 2005

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am using CVSNT on Windows 2000 Pro.  I am also connecting through 
:extssh: protocol using WSAD 5.1.  

I tried symlinking with Cygwin to cvs from cvs.exe and that didn't seem 
to change anything.

I tried copying the cvs.exe from the cvsnt directory into the /usr/bin 
directory of cygwin as 'cvs'.  That didn't change anything.

If I rename the cvs.exe to cvs won't that break pserver?

I tried pserver and pserver is returning "E cvs server", so it seems a 
problem with Cygwin when launching CVSNT executable.  This problem 
doesn't show itself in earlier versions fo CVSNT with Cygwin :extssh:

Tony Hoyle <tony.hoyle at march-hare.com> wrote in news:di6654$qss$2

> Mark Townsend wrote:
>> I got a response from the eclipse.platform newgroup.  They said that 
>> Eclipse 2.x expects "E cvs server" not "E cvs.exe server" which the 
>> latest version of CVSNT put out.  That is why browsing isn't working.  
>> Is there any way to change this output without changing the code?  
>> setting or something?
> It's the name of the application.  It is not constant text and never 
> been.
> OTOH cvsnt on Windows strips the .exe, and won't return 'E cvs.exe 
> server' in any version I can find, until 2.6.x, when it changes 'to 'E 
> cvsnt server'.
> This is exactly the same behaviour as cvs 1.11.x.. just rename or 
> symlink the binary to something else and the message changes.  Eclipse 
> shouldn't be assuming it won't change just because it hasn't yet.
> Tony

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook