[cvsnt] Bizarre problem with cvsnt client and Tortoise CVS

Arthur Barrett arthur.barrett at march-hare.com
Thu Jun 29 13:38:38 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


> For no apparent reason, the cvsnt 
> executable simply fails to connect 
> to any CVS server via the ssh or ext 
> methods. 

I'm sure it didn't simply fail - it probably worked very hard to fail ;)

> I am able to run ssh from the same 
> machine to any of the target CVS 
> servers without any problems, so 
> I know it is not a firewall problem.
> I can run Cygwin cvs with ssh from 
> the command line on the same machine

Surely I need to turn this into a FAQ.

1. don't insall cygwin cvs and CVSNT
2. don't install ssh
3. upgrade to the testing release of 2.5.03 from:

The latest 2.5.03 searches for DLL's using a new system so is more
reliable in DLL hell.

> I've tried using various ssh tools 
> such as TortoisePlink, cygwin ssh 
> and putty and all of them give the 
> same error.

CVSNT includes the putty ssh client, so just use:
cvs -d :ssh:server:/repo login

Oh, and consider commercial support from the vendors in Sydney:


Arthur Barrett

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook