[cvsnt] Bizarre problem with cvsnt client and Tortoise CVS

Craig Southeren craigs at postincrement.com
Thu Jun 29 14:19:39 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

On Thu, 29 Jun 2006 22:38:38 +1000
"Arthur Barrett" <arthur.barrett at march-hare.com> wrote:

> Craig,
> > For no apparent reason, the cvsnt 
> > executable simply fails to connect 
> > to any CVS server via the ssh or ext 
> > methods. 
> I'm sure it didn't simply fail - it probably worked very hard to fail ;)

I agree :)

The trick is finding that reason...
> > I am able to run ssh from the same 
> > machine to any of the target CVS 
> > servers without any problems, so 
> > I know it is not a firewall problem.
> >
> > I can run Cygwin cvs with ssh from 
> > the command line on the same machine
> Surely I need to turn this into a FAQ.
> 1. don't insall cygwin cvs and CVSNT
> 2. don't install ssh

There are very good reasons why I need to have cygwin cvs and ssh on the
same box. They've not interfered with cvsnt at any time in the past, nor
is there any problem on my other boxes which have the same environment.

In any case, I included this info to demonstrate it was not a firewall
problem, and was not PEBCAK

> 3. upgrade to the testing release of 2.5.03 from:
> http://cvsnt.org/wiki/Download

I did try CVSNT (which happens to be the same version as in
Tortoise CVS), but I did not try 

Will these have different behaviour?
> The latest 2.5.03 searches for DLL's using a new system so is more
> reliable in DLL hell.

Are you talking about 2377 here, or 2260 ?

> > I've tried using various ssh tools 
> > such as TortoisePlink, cygwin ssh 
> > and putty and all of them give the 
> > same error.
> CVSNT includes the putty ssh client, so just use:
> cvs -d :ssh:server:/repo login

That didn't work either
> Oh, and consider commercial support from the vendors in Sydney:
> http://march-hare.com/cvsnt/

I might consider this if I was trying to do something special, but this
smelled like an install problem. And this kind of problem is what people
pay *me* to solve :)

And here is a further update:

By regressing my machine to a restore point from yesterday, I was able
to regain functionality. The only thing that had been installed in that
time was the Visual C++ 2005 Redistributable Package (x86).

I agree that the problem is most likely the usual DLL hell, made worse
because the faulty dependency was probably in a run-time loaded module
rather than a startup DLL. Which means there is no useful error message
- just an application failure.


 Craig Southeren          Post Increment – VoIP Consulting and Software
 craigs at postincrement.com.au                   www.postincrement.com.au

 Phone:  +61 243654666      ICQ: #86852844
 Fax:    +61 243656905      MSN: craig_southeren at hotmail.com
 Mobile: +61 417231046      

 "It takes a man to suffer ignorance and smile.
  Be yourself, no matter what they say."   Sting

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook