[cvsnt] Q: cvslock.exe error for "user" but not for "administrator"on Win XP Pro SP2

Arthur Barrett arthur.barrett at march-hare.com
Thu Mar 2 09:54:05 GMT 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


What version of CVSNT are you using now (is it still 2151)?

What is the "error" message?

What is the CVSROOT (it sounds like you are using :local:)?

Is the error originating in the lock server or the cvsnt server or the
cvsnt client?  If it's in the cvslock server, stop the service and run
it in debug mode:
Cvslock -test

There is other information you can supply that helps people answer your


Arthur Barrett

-----Original Message-----
From: cvsnt-bounces at cvsnt.org [mailto:cvsnt-bounces at cvsnt.org] On Behalf
Of Petr Prikryl
Sent: 02 March 2006 19:34
To: cvsnt at cvsnt.org
Subject: [cvsnt] Q: cvslock.exe error for "user" but not for
"administrator"on Win XP Pro SP2


Shortly: I am observing cvslock error when
doing typical cvs operations on Windows XP Pro
SP2 for normal "user" privileges. OK for
"administrator" privileges. How to fix the settings?

(I tried to find the answer, really. Possibly
did not try hard enough. ;)

I am using CVSNT for quite a long time, but
only in a simple environment, i.e. only on my
local computer, not accessible from outside.

Until recently I did use Win 2000 Pro with
no problem [version 2.5.03 (Scorpio) Build 
2151 (client/server)] using administrator's

I have decided to switch to Windows XP Pro SP2
at home and tried to work as a normal user.
I have installed the cvsnt under administrator
and it works fine under administrator. 

When I log-in as a normal user and do
things like 'cvs co...' it seems to work
(and it seems to finish the work), but the 
message about cvslock.exe error appears.

The repository was copied under administrator
privileges to the same place as on the old
computer. I believe I did remove the read-only
attributes (copied via CD).

I believe that it is a well known problem and 
it is only my blindness of some kind. Any
pointer of "Here you are, you stupid: URL..."
is O.K.

Thanks for your time and experience,

Petr Prikryl (prikrylp at skil dot cz) 
cvsnt mailing list
cvsnt at cvsnt.org http://www.cvsnt.org/cgi-bin/mailman/listinfo/cvsnt cvsnt downloads at march-hare.com https://www.march-hare.com/cvspro/en.asp#downcvs @CVSNT on Twitter CVSNT on Facebook

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook