[cvsnt] Troubleshooting CVS login problems

Josh Larsen funinvegas at gmail.com
Tue Oct 17 05:50:49 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I am running CVSNT 2.5.03 (Scorpio) Build 2382
I created a repository (F:/CVS/ejrepo).
Accessing the repository localy (CVSROOT="f:\CVS\ejrepo") I was able
to add a user and associate that user with my real account.  I double
checked teh passwd file to make sure, it contains the line:
scorch:[Passwordish letters here]:Josh

But I am still not able to login using the pserver or any of the other
plugin types I have tried so far.

for example:
cvs.exe -d ":pserver:scorch at\CVS\ejrepo" login
Logging in to :pserver:scorch at\CVS\ejrepo
CVS Password:
cvs2 [login aborted]: Error reading from server -1: Unknown error

Another attempt:
cvs -d ":sspi:scorch at\CVS\ejrepo" login
Logging in to :sspi:scorch at\CVS\ejrepo
CVS Password:
Can't authenticate - server and client cannot agree on an
authentication scheme(got '')

I found a troubleshooting page that recomended running cvsservice.exe
manually, here is the result of that:

cvsservice.exe -test
CVSNT 2.5.03 (Scorpio) Build 2382 (Jul  5 2006) starting in test mode.
TEMP/TMP currently set to F:\CVS\cvstemp
Initialising socket...
Starting auth server on port 2401/tcp...
Couldn't register with active directory: Configuration information could not be
read from the domain controller, either because the machine is unavailable, or a
ccess has been denied.
CVSNT initialised successfully

When I attempt to log in, the cvsservice.exe spits out this:
055d36e8: Cvsnt process started
055d36e8: Cvsnt process terminated

Any idea what is wrong or how to get more information to debug this?

Appricate it,

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook