[cvsnt] Strange behaviour of cvs status on a VMWare server...

Bo Berglund bo.berglund at telia.com
Thu Oct 26 23:06:12 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

On Tue, 24 Oct 2006 21:42:09 +0200, David Somers <dsomers at omz13.com>

>Bo Berglund wrote:
>> I also think that a networking problem is at large here, but I can't
>> figure out what....
>> It looks strange that some commands ooperate OK (cvs log or cvs status
>> on a single file for example) whereas others do not (like the cvs
>> status -v file1 file2 type).
>Or maybe some edge condition involving IO (i.e. networking and disk IO).
>> Anyways the virtual machine has a VMWare virtual network adapter and
>> the IT person today tried to clean out all of the drivers for now
>> nonexisting hardware. But so far it has not helped.
>> The VMWare network adapter is connected to a virtual network switch on
>> the server and the output of that is in turn connected to the physical
>> network adapter on the server PC. According to the IT person the
>> virtual switch is a beast to configure and whatever they do will
>> affect all servers sunning on the same hardware PC, so they are
>> reluctant to change the defaults....
>Just depends how its been set up... probably best that each virtual server
>has its own manually specified IP address; don't share the physical host's
>IP address across the virtual hosts.

I think that the virtual switch is just like a hardware switch that
routes the different VM:s into the real NIC and then out to the
The IP address is as before and DNS is not an issue, I can easily ping
by name and the PC is after all an image of the old one, same name

In any case we sorted out one strangeness that pointed to permissions:
When I did a graph on a file from my PC it worked fine, but when
another guy did exactly the same from his WinCvs just hung.
This was caused by something that I have seen before but it was not
easily detected, it took a while experimenting between WinCvs and the
command window:
WinCvs had a global option to use compression set up on the other
guy:s PC. He had set it for high so the cvs command started out as 
cvs -z9 log....
As soon as I removed the z9 his started to work like my PC and graph
works now on both.

However, there is still the problem of cvs status (and possibly some
other commands). It is bugging the hell out of me.
ALL commands we are having problems with from client workstations work
flawlessly when executed in a command window on the server itself!

Why this happens is beyond me and it sure looks like a networking
problem. The status commands produce the start of a display, sometimes
only the leading ==================== line and sometimes a few lines
more, but then it invariably stops.
This always happens with cvs status -v file1 file2, and sometimes also
with only one file mentioned.
But never with cvs status -q ....

Why is there a difference?

Would upgrading the server to build 2382 make a difference? It runs
2151 right now.


(Bo Berglund, developer in Sweden)

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook