[cvsnt] Bug: Unicode(-ku) file with branch producing weird empty lines

Winston Feng tifish at 163.com
Tue Sep 19 09:37:18 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

I found after branching an unicode(-ku) file, the file produced some
weird empty lines. Here's what I do:

1. Create a UTF-16LE file with 2 lines like:
2. Add the file with -ku, and commit it.
3. Create a branch on the file.
4. Delete the file, and update it.

The file I got has a new empty line between the "aaa" and "bbb"!

It seems every line ending of the unicode file will produce a new empty
line. I've tried -kuo but got the same result.

The CVSNT Server is 2.5.03 (Scorpio) Build 2382.
The client is TortoiseCVS 1.8.27, using pserver.


Winston Feng

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook