[cvsnt] odd behavior of template for rcsinfo

Joe.VanQuakebeke at Ingenix.com Joe.VanQuakebeke at Ingenix.com
Tue Sep 19 14:57:09 BST 2006

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

    I had my template file working on windows and Linux just fine a
while ago.  My windows repository still works exactly as it should.  My
Linux repository does not.  
    The problem is that my template file is not being fully created on
checkout whether I am on Linux or Windows.  I get the Template file in
the CVS directory but it only has the first character of the template
file.  I have tried different templates, making the template part of the
CVS files by editing checkoutlist, changing the path to somewhere
outside of CVSROOT and nothing is working.  I think a daemon died or is
in a bad status on the server, but it isn't cvslockd.  I have
stopped/started the cvslockd and checked the status.  Is there some
other daemon that could be causing this problem.  I know it isn't cvsnt
because I am running the same build on Windows and Linux. 
    I also thought it could have something to do with line endings, so I
ran unix2dos on the template file and it still fails.  I also created
the file in notepad and added it to the repository from windows and I
still have the same issue. 
    We are using cvsnt 2.5.03 Build 2382.  (Client and Server)  My Linux
is RHAT EL 4.0 on a 2 cpu system.  I looked in /var/log/messages and
boot.log and didn't see any errors or warnings.  
    I don't get any error messages and I tried using the -ttt trace
level but I could find anything about the Template.  I even set the
trace level all the way to 7 and didn't see anything.
    I also tried a different repository with a different template file
and I have the same results.  Everything works great on windows and
fails on Linux.   
    Everything else works great on Linux.  All my checkin's, tagging,
commits, and etc all function great.  It is just the rcsinfo and
template files that are causing problems.  
    Because I have tried a totally different repository, I don't think
the problem is my repository.

	AFAIK, nothing on the Linux server has changed either. 


"Secure Server GDV" made the following
 annotations on 09/19/2006 08:57:11 AM
------------------------------"This e-mail, including attachments, may include confidential and/or proprietary information, and may be used only by the person or entity to which it is addressed. If the reader of this e-mail is not the intended recipient or his or her authorized agent, the reader is hereby notified that any dissemination, distribution or copying of this e-mail is prohibited. If you have received this e-mail in error, please notify the sender by replying to this message and delete this e-mail immediately."

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook