[cvsnt] protocol_map.ini no longer supported?

Daniel Krügler daniel.kruegler at googlemail.com
Thu Apr 26 13:21:48 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I'm using the recently recommended version cvsnt
I need to map the protocol type "extssh" and therefore tried
to use protocol_map.ini, because of the error message

"the :extssh: access method is not available on this system"

Doing this I stumbled across two problems:

1) The state of the file obviously does not reflect the current 
implementation state, e.g. there exists the mapping

gserver = gserver_protocol.dll

but there is no gserver_protocol.dll any more. In contrast, those
protocol dll's have moved into a separate directory "protocols".
So how should be the adapted mapping syntax?

2) Going into the same line, I also found that extssh was already
mapped as

extssh = ssh_protocol.dll

which does not work according to reasons explained in (1)

I also noted that there was a careful analysis of this problem
by Gernot Hüller found at:


Unfortunatly it seems that this message was not taken into the
account (i.e. it did not become part of the bug tracking system,
at least I could not find it in the existing bug list).

I would appreciate, if someone could

(a) put this error into the bug database
(b) if possible: can anyone describe a simple workaround for this
problem?(*) Maybe I used the wrong syntax to define the mapping?

I tried both of

extssh = protocols/ssh.dll


extssh = protocols\ssh.dll

but was not successful.

Thanks in advance,

Daniel Krügler

(*) Changing the protocol type inside the .cvs/root file is *not*
an option for me, because I use this via two different clients.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook