[cvsnt] Problem merging file added on HEAD into a branch

Bartolomeo Nicolotti bnicolotti at siapcn.it
Fri Jul 20 12:29:53 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.

Yes, I think you're right! Here's the log for the added file:

RCS file:
Working file: JavaSource/APUtility/NameTypeValVector.java
head: 1.2
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 2;     selected revisions: 2
revision 1.2
date: 2007/07/18 17:32:36;  author: bnicolotti;  state: dead;  lines: +0 -0
Per problema riporto added da HEAD a branch
revision 1.1
date: 2007/07/17 12:58:33;  author: bnicolotti;  state: Exp;
Per gestire elenchi di triple (nome campo, tipo, valore)

But I tried to update and it seemed not to work. I worked around the
problem renaming the file on the branch and merging to HEAD. For now it's
ok, next time i'll keep your suggestion in mind. THANKS!

Bartolomeo Nicolotti wrote:

> I've added a file to the HEAD trunk with other changes that I wanted to
merge into a branch, so I committed everything on the HEAD, switched to
the branch and did:
> ...
> cvs update -j HEAD addedfile.txt
> ...
> Then doing cvs -n update it correctly gave
> ...
> A addedfile.txt
> ...
> but when I tried to commit the added file in the branch cvs gave the
> Conflict, the file addedfile.txt was already added.

Not sure, but what happens when you now update the branch? Does it stay or
does it go away? If it stays, the merge somehow already marked the file as
now being on the branch, without an actual commit on the branch.


Bartolomeo Nicolotti
SIAP Sistemi Applicativi s.r.l.

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook