[cvsnt] Rename - what am I doing wrong?

Gerhard Fiedler lists at connectionbrazil.com
Fri Jul 20 14:54:29 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I haven't used rename a whole lot yet. It has worked for me before, but not
this time. It seems to work for many if used correctly -- so what am I
doing wrong here?

<e:\test\1\2\Docs>12>cvs ren Design.doc Simple-Design.doc
cvs rename: Warning: rename is still experimental and may not behave as you
would expect

<e:\test\1\2\Docs>13>cd ..

<e:\test\1\2>14>cvs ci -m "rename Design.doc"
cvs commit: Examining .
cvs commit: Examining Docs

After this, if I do a checkout of 1/2/Docs, I still get the old name. I
also tried "cvs ci -m "rename Design.doc" Docs" as commit command, with the
same result. ("1" is a top level module in my repository.)

Isn't this how it is supposed to work? 

Thanks for any help,

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook