[cvsnt] Problem with cvs on WinVista, instalation, cvs diff strange behaviour...

Petr Prikryl PrikrylP at skil.cz
Tue May 22 14:20:07 BST 2007

Community technical support mailing list was retired 2010 and replaced with a professional technical support team. For assistance please contact: Pre-sales Technical support via email to sales@march-hare.com.


I am observing weird problem with CVSNT on Windows Vista.
I do not know where to start; so, I try to describe what
I think could be important. Thanks for being patient...

Some context information is necessary first...

I tried to install the CVSNT from the package
cvsnt-server- on Windows Vista. The problem
is that the CVSNT Control Panel does not work.

Because of that I uninstalled the CVSNT and 
tried evs The control
panel works here, but I cannot transfer and use my 
repository. However, the information set from EVS 
Control Panel (about where my cvsrootXXX repository
is placed) fortunately stays in registry even after
uninstalling the EVS.

Then I installed the CVSNT again. Control
Panel still does not work, but the information in registry
remains. This way I could zip and transfer
my repository from the older machine. I also successfully
created the working copy of my project on the new machine.
It compiles fine and it looks as if everything is O.K.

However, some things look really strange. For example...

1) When I get a copy of older version of a file, it
   is O.K.
2) When I get a copy of up-to-date version of the file,
   it is also O.K...
3) ... but when I try "cvs diff -r older -r newer"
   I get the result that says that the version number
   differs but not the content. However, the content
   IS different.

I guess the problem will be difficult to reproduce.
So, I put some files to the web...
   http://www.skil.cz/cvsdiff/test1.zip (about 3 KB)
   http://www.skil.cz/cvsdiff/test2.zip (about 3 KB)
   http://www.skil.cz/cvsdiff/version.zip (about 157 KB)

The version.zip contains version.inc,v file from 
the repository -- location 
The e:/cvsrootAPSm3 was mapped via EVS Control Panel
as /cvsrootAPSm3. 

The test1.zip contains working copy created by the command
    cvs -d :sspi:localhost:/cvsrootAPSm3 co -d test1
Then it was zipped using InfoZIP's zip.exe this way:
    zip -rS test1 test1

The test2.zip contains working copy created by the command
    cvs -d :sspi:localhost:/cvsrootAPSm3 co -d test2 -r v303h5
Then, from inside the test2 directory, the following
command was executed:
    cvs diff -r v303h5 -r v303i >ddd.bak
(The v303i tag belongs to the newest version of the file.)
Then test2 was zipped from upper directory using
    zip -rS test2 test2
so that it contains also the ddd.bak. 

Have a look at test1/version.inc, test2/version.inc, 
and the ddd.bak that should reflect the changes. (Ignore
the funny 8-bit characters in comments -- Czech language,

Any idea? Can you see any bug in my attempt to install 
the CVSNT on Windows Vista? Possibly, could the encoding
cause the problem. The Windows Vista are English. 
Feel free to ask for publishing the files/information 
that could help to disclose the problem.


Thanks for your help,

More information about the cvsnt mailing list
Download the latest CVSNT, TortosieCVS, WinCVS etc. for Windows 8 etc.
@CVSNT on Twitter   CVSNT on Facebook